Installation

This plugin requires Python version 3.6 or above, as well as PennyLane and Cirq. Installation of this plugin, as well as all dependencies, can be done using pip:

$ pip install pennylane-cirq

Alternatively, you can install PennyLane-Cirq from the source code by navigating to the top directory and running:

$ python setup.py install

Dependencies

PennyLane-Cirq requires the following libraries be installed:

as well as the following Python packages:

To use the qsim and qsimh devices, the qsim-Cirq interface qsimcirq is required:

It can be installed using pip:

$ pip install qsimcirq

If you currently do not have Python 3 installed, we recommend Anaconda for Python 3, a distributed version of Python packaged for scientific computation.

Tests

To test that the PennyLane-Cirq plugin is working correctly you can run

$ make test

in the source folder.

Documentation

To build the HTML documentation, go to the top-level directory and run:

$ make docs

The documentation can then be found in the doc/_build/html/ directory.